OpenRoads Designer CONNECT Edition SDK Help

ProfileCircularArc Properties

Properties

CenterPoint Gets the center point of circular arc
EndLocalAbscissa Gets the end parameter of the circular arc
EndSlope Gets the end slope of the circular arc
LeftLength Gets left length of the circular arc
LeftTangent Gets the left tangent of the circular arc
ProjectedLength Gets projected length of the circular arc (Overrides ProfileElement.ProjectedLength)
Radius Gets the radius of circular arc
RightLength Gets right length of the circular arc
RightTangent Gets the right tangent of the circular arc
StartDirection Gets the start direction of circular arc
StartLocalAbscissa Gets the start parameter of the circular arc
StartSlope Gets the start slope of the circular arc
SweepAngle Gets the sweep angle of circular arc
VPIPoint Gets VPI point of the circular arc

See Also